Spotler

Email delivery delays to Microsoft/Outlook addresses

Incident Report for Spotler

Resolved

Microsoft confirmed that service had been restored 18:12 CEST on Friday evening.
Posted Sep 07, 2026 - 09:43 CEST

Identified

We're aware some emails to Microsoft-managed addresses (e.g. Outlook, Office 365) are being delayed. This is a known, global Microsoft issue — not specific to Spotler — and there's no action needed on your part. Queued emails will deliver automatically once Microsoft resolves it.
Posted Sep 04, 2026 - 11:39 CEST
This incident affected: Activate, ActivatePro, Chat+, Connect, CRM, Engage, FeedbackPro, GatorMail, Leads, Mail+, MailPro, Message, Momice, Predict, Search, and SendPro.