Spotler

Mail+ - static.mailplus.nl unavailable

Incident Report for Spotler

Resolved

This incident has now been resolved.
Posted Sep 02, 2026 - 13:10 CEST

Monitoring

The services are back up and running and we're monitoring closely.
Posted Sep 01, 2026 - 11:10 CEST

Identified

The issue has been identified and investigation is ongoing.
Posted Sep 01, 2026 - 10:30 CEST

Investigating

We are currently investigating an issue that may be resulting in forms not rendering properly on websites and causing HTTP 504 errors in the console.
Posted Sep 01, 2026 - 10:08 CEST
This incident affected: Mail+.