Spotler

Activate - Queue Delays

Incident Report for Spotler

Postmortem

Between 12:00 CEST on 28 June 2026 and 17:00 CEST on 29 June 2026, customers experienced delays in data processing. The issue has been fully resolved and all backlogged processing has caught up. No data was lost.

What happened: Increased load on an internal system caused a temporary backlog in processing.

Resolution: Our team applied fixes to resolve the underlying load issue, restoring normal performance and clearing the backlog the same day.

Next steps: We're rolling out permanent changes and additional monitoring to help prevent similar issues in future.

Posted Jun 30, 2026 - 16:46 CEST

Resolved

Following extensive monitoring, we can now confirm that this has been fully resolved. Post Mortem will follow in the coming days.
Posted Jun 30, 2026 - 11:14 CEST

Monitoring

Following the earlier patch and continued improvements, the queue is clearing down, albeit still slower than expected. We're monitoring the situation closely and we expect the queue to be caught up and back to normal overnight.
Posted Jun 29, 2026 - 13:35 CEST

Identified

The issue has been identified and an initial patch has been released to help handle the queue. Investigation is ongoing at this time.
Posted Jun 29, 2026 - 12:22 CEST

Investigating

We are currently investigating a queue build-up within the platform. Currently, data is not being processed in the expected timeframe and as such, delays can be expected with data processing. This is impacting things like data upload, audience building and journey progression.
Posted Jun 29, 2026 - 12:05 CEST
This incident affected: Activate.