Spotler

Integration Platform - HTTP 400 Errors

Incident Report for Spotler

Postmortem

On 24th June, between approximately 13:30 and 17:00 CEST webhook delivery for some integrated customers was disrupted. The cause was available disk space on a platform component falling below a safe operating threshold. An existing monitoring alert did not fire as expected, which delayed our detection and response.

Webhooks and API calls towards the integration platform returned 4xx/5xx error and their contents have not been stored or retried. Meaning data sent during this window may not have been received by the integration platform if webhooks are the only way of communication to the integration platform. Rest API was un-affected.

We have resolved the underlying disk space issue and have corrected the alerting configuration to ensure this class of problem is detected promptly in future.

Posted Jun 25, 2026 - 09:45 CEST

Resolved

This has now been confirmed as resolved following extensive monitoring.
Posted Jun 25, 2026 - 09:33 CEST

Monitoring

We experienced an issue between approximately 13:30 and 16:50 affecting webhook delivery for Connect customers. Requests during this window returned errors and were not queued for retry, meaning some data may not have been received. The issue has been resolved and normal service has resumed. We apologise for any inconvenience caused.
Posted Jun 24, 2026 - 17:21 CEST
This incident affected: Activate, Connect, CRM, and MailPro.